Reactor Dependency Convergence

Legend:
[Error]
At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of modules: 17
Number of dependencies (NOD): 258
Number of unique artifacts (NOA): 285
Number of version-conflicting artifacts (NOC): 10
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA):
[Error]
 90 %
Ready for release (100% convergence and no SNAPSHOTS):
[Error]
 Error
You do not have 100% convergence.

Dependencies used in modules

org.apache.commons:commons-text

[Error]
1.7
  1. com.graphql-java-generator:graphql-maven-plugin-samples-StarWars-server:war:1.14
    \- com.opencsv:opencsv:jar:5.0:compile
       \- org.apache.commons:commons-text:jar:1.7:compile

1.8
  1. com.graphql-java-generator:graphql-maven-plugin-samples-StarWars-server:war:1.14
    \- com.graphql-java-kickstart:graphiql-spring-boot-starter:jar:11.0.0:runtime
       \- com.graphql-java-kickstart:graphiql-spring-boot-autoconfigure:jar:11.0.0:runtime
          \- (org.apache.commons:commons-text:jar:1.8:runtime - omitted for conflict with 1.7)

org.apache.maven:maven-builder-support

[Error]
3.3.9
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    \- org.apache.maven:maven-core:jar:3.6.3:compile
       \- org.apache.maven:maven-settings-builder:jar:3.6.3:compile
          \- (org.apache.maven:maven-builder-support:jar:3.3.9:compile - omitted for conflict with 3.6.3)

3.6.3
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    \- org.apache.maven:maven-core:jar:3.6.3:compile
       +- org.apache.maven:maven-builder-support:jar:3.6.3:compile
       \- org.apache.maven:maven-model-builder:jar:3.3.9:compile
          \- (org.apache.maven:maven-builder-support:jar:3.6.3:compile - omitted for duplicate)

org.apache.maven:maven-model-builder

[Error]
3.3.9
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    +- org.apache.maven:maven-aether-provider:jar:3.3.9:test
    |  \- (org.apache.maven:maven-model-builder:jar:3.3.9:compile - scope updated from test; omitted for duplicate)
    \- org.apache.maven:maven-core:jar:3.6.3:compile
       \- org.apache.maven:maven-model-builder:jar:3.3.9:compile

3.6.3
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    +- org.apache.maven:maven-compat:jar:3.6.3:test
    |  \- (org.apache.maven:maven-model-builder:jar:3.6.3:test - omitted for conflict with 3.3.9)
    \- org.apache.maven:maven-core:jar:3.6.3:compile
       \- org.apache.maven:maven-resolver-provider:jar:3.6.3:compile
          \- (org.apache.maven:maven-model-builder:jar:3.6.3:compile - omitted for conflict with 3.3.9)

org.apache.maven:maven-repository-metadata

[Error]
2.2.1
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    \- org.apache.maven:maven-project:jar:2.2.1:compile
       \- org.apache.maven:maven-artifact-manager:jar:2.2.1:compile
          \- (org.apache.maven:maven-repository-metadata:jar:2.2.1:compile - omitted for conflict with 3.3.9)

3.3.9
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    +- org.apache.maven:maven-aether-provider:jar:3.3.9:test
    |  \- (org.apache.maven:maven-repository-metadata:jar:3.3.9:compile - scope updated from test; omitted for duplicate)
    \- org.apache.maven:maven-core:jar:3.6.3:compile
       \- org.apache.maven:maven-repository-metadata:jar:3.3.9:compile

3.6.3
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    +- org.apache.maven:maven-compat:jar:3.6.3:test
    |  \- (org.apache.maven:maven-repository-metadata:jar:3.6.3:test - omitted for conflict with 3.3.9)
    \- org.apache.maven:maven-core:jar:3.6.3:compile
       \- org.apache.maven:maven-resolver-provider:jar:3.6.3:compile
          \- (org.apache.maven:maven-repository-metadata:jar:3.6.3:compile - omitted for conflict with 3.3.9)

org.apache.maven:maven-settings

[Error]
2.2.1
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    \- org.apache.maven:maven-project:jar:2.2.1:compile
       \- (org.apache.maven:maven-settings:jar:2.2.1:compile - omitted for conflict with 3.6.3)

3.6.3
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    +- org.apache.maven:maven-compat:jar:3.6.3:test
    |  \- (org.apache.maven:maven-settings:jar:3.6.3:compile - scope updated from test; omitted for duplicate)
    \- org.apache.maven:maven-core:jar:3.6.3:compile
       +- org.apache.maven:maven-settings:jar:3.6.3:compile
       \- org.apache.maven:maven-settings-builder:jar:3.6.3:compile
          \- (org.apache.maven:maven-settings:jar:3.6.3:compile - omitted for duplicate)

org.codehaus.plexus:plexus-classworlds

[Error]
2.5.2
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    \- org.apache.maven:maven-core:jar:3.6.3:compile
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.4:compile
          \- (org.codehaus.plexus:plexus-classworlds:jar:2.5.2:compile - omitted for conflict with 2.6.0)

2.6.0
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    +- org.apache.maven:maven-core:jar:3.6.3:compile
    |  \- org.codehaus.plexus:plexus-classworlds:jar:2.6.0:compile
    \- org.apache.maven:maven-plugin-api:jar:3.6.3:compile
       \- (org.codehaus.plexus:plexus-classworlds:jar:2.6.0:compile - omitted for duplicate)

org.codehaus.plexus:plexus-component-annotations

[Error]
1.5.5
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    \- org.apache.maven:maven-core:jar:3.6.3:compile
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.4:compile
          \- (org.codehaus.plexus:plexus-component-annotations:jar:1.5.5:compile - omitted for conflict with 2.1.0)

1.6
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    \- org.apache.maven:maven-aether-provider:jar:3.3.9:test
       \- (org.codehaus.plexus:plexus-component-annotations:jar:1.6:compile - scope updated from test; omitted for duplicate)

2.1.0
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    +- org.apache.maven:maven-compat:jar:3.6.3:test
    |  \- (org.codehaus.plexus:plexus-component-annotations:jar:2.1.0:test - omitted for conflict with 1.6)
    \- org.apache.maven:maven-core:jar:3.6.3:compile
       \- org.codehaus.plexus:plexus-component-annotations:jar:2.1.0:compile

org.codehaus.plexus:plexus-interpolation

[Error]
1.11
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    \- org.apache.maven:maven-project:jar:2.2.1:compile
       +- org.apache.maven:maven-profile:jar:2.2.1:compile
       |  \- (org.codehaus.plexus:plexus-interpolation:jar:1.11:compile - omitted for conflict with 1.25)
       \- org.codehaus.plexus:plexus-interpolation:jar:1.11:compile

1.25
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    +- org.apache.maven:maven-compat:jar:3.6.3:test
    |  \- (org.codehaus.plexus:plexus-interpolation:jar:1.25:compile - scope updated from test; omitted for duplicate)
    \- org.apache.maven:maven-core:jar:3.6.3:compile
       +- org.apache.maven:maven-settings-builder:jar:3.6.3:compile
       |  \- (org.codehaus.plexus:plexus-interpolation:jar:1.25:compile - omitted for conflict with 1.11)
       \- org.apache.maven:maven-model-builder:jar:3.3.9:compile
          \- (org.codehaus.plexus:plexus-interpolation:jar:1.25:compile - omitted for duplicate)

org.codehaus.plexus:plexus-utils

[Error]
1.0.4
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    \- org.apache.maven:maven-project:jar:2.2.1:compile
       \- org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1:compile
          \- (org.codehaus.plexus:plexus-utils:jar:1.0.4:compile - omitted for conflict with 3.0.22)

1.4.2
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    \- org.apache.maven:maven-project:jar:2.2.1:compile
       \- org.apache.maven:maven-artifact-manager:jar:2.2.1:compile
          \- org.apache.maven.wagon:wagon-provider-api:jar:3.3.4:compile
             \- (org.codehaus.plexus:plexus-utils:jar:1.4.2:compile - omitted for conflict with 3.0.22)

1.5.15
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    \- org.apache.maven:maven-project:jar:2.2.1:compile
       +- org.apache.maven:maven-profile:jar:2.2.1:compile
       |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.15:compile - omitted for conflict with 3.0.22)
       +- org.apache.maven:maven-artifact-manager:jar:2.2.1:compile
       |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.15:compile - omitted for conflict with 3.0.22)
       +- org.apache.maven:maven-plugin-registry:jar:2.2.1:compile
       |  \- (org.codehaus.plexus:plexus-utils:jar:1.5.15:compile - omitted for conflict with 3.0.22)
       \- (org.codehaus.plexus:plexus-utils:jar:1.5.15:compile - omitted for conflict with 3.0.22)

1.5.5
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    \- org.apache.maven:maven-core:jar:3.6.3:compile
       \- org.apache.maven:maven-settings-builder:jar:3.6.3:compile
          \- org.sonatype.plexus:plexus-sec-dispatcher:jar:1.4:compile
             \- (org.codehaus.plexus:plexus-utils:jar:1.5.5:compile - omitted for conflict with 3.0.22)

3.0
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    \- org.apache.maven.plugin-testing:maven-plugin-testing-harness:jar:3.3.0:test
       \- org.codehaus.plexus:plexus-archiver:jar:2.2:test
          \- org.codehaus.plexus:plexus-io:jar:2.0.4:test
             \- (org.codehaus.plexus:plexus-utils:jar:3.0:test - omitted for conflict with 3.0.7)

3.0.17
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    \- org.apache.maven:maven-core:jar:3.6.3:compile
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.4:compile
          \- (org.codehaus.plexus:plexus-utils:jar:3.0.17:compile - omitted for conflict with 3.0.22)

3.0.22
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    +- org.apache.maven:maven-aether-provider:jar:3.3.9:test
    |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.22:compile - scope updated from test; omitted for duplicate)
    \- org.apache.maven:maven-artifact:jar:3.6.3:compile
       \- org.codehaus.plexus:plexus-utils:jar:3.0.22:compile

3.0.7
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    \- org.apache.maven.plugin-testing:maven-plugin-testing-harness:jar:3.3.0:test
       \- org.codehaus.plexus:plexus-archiver:jar:2.2:test
          \- (org.codehaus.plexus:plexus-utils:jar:3.0.7:test - omitted for conflict with 3.0.22)

3.2.1
  1. com.graphql-java-generator:graphql-maven-plugin:maven-plugin:1.14
    +- org.apache.maven:maven-compat:jar:3.6.3:test
    |  \- (org.codehaus.plexus:plexus-utils:jar:3.2.1:test - omitted for conflict with 3.0.22)
    +- org.apache.maven:maven-core:jar:3.6.3:compile
    |  +- org.apache.maven:maven-settings:jar:3.6.3:compile
    |  |  \- (org.codehaus.plexus:plexus-utils:jar:3.2.1:compile - omitted for conflict with 3.0.22)
    |  +- org.apache.maven:maven-settings-builder:jar:3.6.3:compile
    |  |  \- (org.codehaus.plexus:plexus-utils:jar:3.2.1:compile - omitted for conflict with 3.0.22)
    |  +- org.apache.maven:maven-repository-metadata:jar:3.3.9:compile
    |  |  \- (org.codehaus.plexus:plexus-utils:jar:3.2.1:compile - omitted for conflict with 3.0.22)
    |  +- org.apache.maven:maven-model-builder:jar:3.3.9:compile
    |  |  \- (org.codehaus.plexus:plexus-utils:jar:3.2.1:compile - omitted for conflict with 3.0.22)
    |  +- org.apache.maven:maven-resolver-provider:jar:3.6.3:compile
    |  |  \- (org.codehaus.plexus:plexus-utils:jar:3.2.1:compile - omitted for conflict with 3.0.22)
    |  \- (org.codehaus.plexus:plexus-utils:jar:3.2.1:compile - omitted for conflict with 3.0.22)
    +- org.apache.maven:maven-model:jar:3.6.3:compile
    |  \- (org.codehaus.plexus:plexus-utils:jar:3.2.1:compile - omitted for conflict with 3.0.22)
    \- org.apache.maven:maven-plugin-api:jar:3.6.3:compile
       \- (org.codehaus.plexus:plexus-utils:jar:3.2.1:compile - omitted for conflict with 3.0.22)

org.objenesis:objenesis

[Error]
2.5.1
  1. com.graphql-java-generator:graphql-maven-plugin-samples-StarWars-client:jar:1.14
    \- org.awaitility:awaitility:jar:3.0.0:test
       \- org.objenesis:objenesis:jar:2.5.1:test

2.6
  1. com.graphql-java-generator:graphql-maven-plugin-samples-StarWars-client:jar:1.14
    \- org.springframework.boot:spring-boot-starter-test:jar:2.4.0:test
       \- org.mockito:mockito-core:jar:2.21.0:test (version managed from 3.6.0)
          \- (org.objenesis:objenesis:jar:2.6:test - omitted for conflict with 2.5.1)